WordPress Blog

Forumlarınız için bbPress 0.9 Çıktı

08.04.2008 | Haberler

Daha çok WordPress bloglarında kullanılan forum scripti bbPress in 0.9 versiyonu duyuruldu. Brubeck kod adıyla yayımlanan forum scriptini herzamanki gibi bbpress.org/latest.zip adresinden indirebilirsiniz. Varolan forumunuzu güncellemek için ise aşağıdaki yönergeleri takip etmeniz gerekiyor;

  • İlk olarak herşeyin yedeğini alın. Kodların ve veritabanının.
  • Tüm eklentileri etkisizleştirin.
  • config.php dosyanızın adını değiştirin, config.old.php yapın.
  • Yeni bbPress 0.9 dosyalarını sunucunuza gönderin
  • bbPress forum adresini yazarak yüklemeyi çalıştırın.
  • Yüklemenin birinci adımında, sizden istenen yere daha önce kullandığınız veritabanı adını girin.
  • Yeni yükleme sihirbazı sizin için başka bir config.php dosyası oluşturacak, eğer oluşturamaz ise bb-config-sample.php dosyasından ve eski config.old.php dosyanızdan yararlanarak oluşturun.
  • From başlangıç sayfasına gelin ve keymaster olarak giriş yapın, “admin? bölümüne gelin.
  • Sizden yüklemeyi güncellemeniz istenecektir.
  • Güncelleme tamamlanıca, ayarlar kısmına gelin
  • Genel sekmesi altındaki bazı kısımları düzeltin.
  • WordPress kullanıcı bilgileri ile forum kullanıcı bilgilerinin aynı olmasını için WordPress Integration kısmını kullanın.
  • Eklentileri tek tek aktifleştirerek test edin ve keyifle kullanmaya devam edin.

Buradaki adımlar http://bbpress.org/documentation/upgrading/ adresinden yararlanılarak yazılmıştır. Planet WordPress Forumumun güncellemesini gerçekleştirdim. Güncellemeyi yaparken bb-config.php dosyasında bazı sorunlarla karşılaştım, ben de eski config.php dosyasının içeriğine şu satırı ekledim;

$bb->uri = 'http://www.planetwp.com/forum/';

ve bb-config.php olarak kaydettim. Sorunsuz kullanıyorum. Sanırım bir alt klasörde kurulu olmasından kaynaklanan bir sorun. Ya yeni yüklemedeki konfigürasyon sihirbazında eksik giriş yaptım, ya da sihirbaz eksik çalışıyor. Herneyse, WordPress 2.5 ile daha güvenli bir şekilde çalışacak olan bbpress’in bu versiyonunda oldukça fazla güncelleme ve düzeltme mevcut. Eğer blogunuzu wordpress 2.5 e yükselmiş iseniz forumunuzu da bbpress 0.9 a yükseltmenizi tavsiye ediyoruz..

« | »

Bu yazıya link verenler: